package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?x)([^\s:,]+)(?#get field)
:[ ]*(?#get separator)
([^,\{\}\n\[\]\s][^,\n]*)(?#get value)`)
var str = `{
field-1: "field value 1",
field2:"field 2","fieldThree": "value field param {three} ",
"subobject":{
"subfield1":1.1,
"sub-field-2":"subval [1.2]",
"sub-subobject":{
"sub_subfield1":"sub sub field 1 ~",
"sub_subfield2":"sub sub field 2 !@#$%/"
}
},
"array":[
{ objectA:01, objectAA:02 },
{ objectB:01, objectBB:02 }
]
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}