use strict;
my $str = '{
field-1: "field value 1",
field2:"field 2","fieldThree": "value field param {three} ",
"subobject":{
"subfield1":1.1,
"sub-field-2":"subval [1.2]",
"sub-subobject":{
"sub_subfield1":"sub sub field 1 ~",
"sub_subfield2":"sub sub field 2 !@#$%/"
}
},
"array":[
{ objectA:01, objectAA:02 },
{ objectB:01, objectBB:02 }
]
}';
my $regex = qr/([^\s:,]+)(?#get field)
:[ ]*(?#get separator)
([^,\{\}\n\[\]\s][^,\n]*)(?#get value)/xp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}