import re
regex = re.compile(r"""
([^\s:,]+)(?#get field)
:[ ]*(?#get separator)
([^,\{\}\n\[\]\s][^,\n]*)(?#get value)
""", flags=re.VERBOSE)
test_str = ("{\n"
" field-1: \"field value 1\",\n"
" field2:\"field 2\",\"fieldThree\": \"value field param {three} \",\n"
" \"subobject\":{\n"
" \"subfield1\":1.1,\n"
" \"sub-field-2\":\"subval [1.2]\",\n"
" \"sub-subobject\":{\n"
" \"sub_subfield1\":\"sub sub field 1 ~\",\n"
" \"sub_subfield2\":\"sub sub field 2 !@#$%/\"\n"
" }\n"
" },\n"
" \"array\":[\n"
" { objectA:01, objectAA:02 },\n"
" { objectB:01, objectBB:02 }\n"
" ]\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")