$re = '/https:\/\/.*\/(.*)\/(.*)$/m';
$str = 'https://www.labnol.org/internet/duplicate-gmail-draft-emails/29124';
$subst = "$1-$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;