re = /^\+(\d{3}|\d{2}|\d{1})\s\((\d{3}|\d{2}|\d{1})\)\s(\d{3}|\d{2}|\d{1})\-(\d{2}|\d{1})\-(\d{2}|\d{1})/m
str = '+189 (377) 123-12-34
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end