re = /^(?i)(https?:\/\/)?(www\.)?facebook\.com\/group(s)?(\/?\/\d+)?(\/.*)?$/m
str = 'Https://wWw.facebook.Com/GROUpS/2233223616820715
httpS://Www.FACEBOOk.cOm/grouP/2233223616820715/?hoisteD_section_header_type=recentLY_seen&multi_permalinks=2744661819010223
https://www.facebook.com/groups/ukrainianenglishclubrachk21312Y
https://www.facebook.com/groups/ukrainianenglishclubrachky/events/fd
Http://wWw.facebook.Com/GROUpS/hhGGGh/22332
http://Www.FACEBOOk.cOm/grouP/2233223616820715/?hoisteD_section_header_type=recentLY_seen&multi_permalinks=2744661819010223
httP://www.facebook.com/groups/ukrainianenglishclubrachk21312Y
http://www.facebook.com/groups/ukrainianenglishclubrachky/events/fd
wWw.facebook.Com/GROUpS/2233223616820715
Www.FACEBOOk.cOm/grouP/2233223616820715/?hoisteD_section_header_type=recentLY_seen&multi_permalinks=2744661819010223
www.facebook.com/groups/ukrainianenglishclubrachk21312Y
www.facebook.com/groups/ukrainianenglishclubrachky/events/fd
facebook.Com/GROUpS/2233223616820715
FACEBOOk.cOm/grouP/2233223616820715/?hoisteD_section_header_type=recentLY_seen&multi_permalinks=2744661819010223
facebook.com/group/ukrainianenglishclubrachk21312Y
facebook.com/groups/ukrainianenglishclubrachky/events/fd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end