$re = '/\$\{(\"[^\"]*\"|\w+(?:\(\))?(?:\.\w+(?:\(\))?)*)}/m';
$str = '${test.one}${test.two}
${test.one}${test.two()}
${test.one}${"hello"}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);