re = /\$\{(\"[^\"]*\"|\w+(?:\(\))?(?:\.\w+(?:\(\))?)*)}/m
str = '${test.one}${test.two}
${test.one}${test.two()}
${test.one}${"hello"}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end