re = /(?<![^;\n])\s*(import)/m
str = 'import sadfsda; import asdf sdaf
import asdfas dfasdf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end