$re = '/(?s)<div.*?FALSE.*?<\/div>/m';
$str = '<div>
TRUE
</div>
<div>
FALSE
</div>
<div>
MAYBE
</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);