$re = '/(?<=KUTY01\s)-?\d+\.?\d+/m';
$str = 'DELZZ 3301.23
KUTY 4.32 SERI -0.023
KUTY01 33.02
Fuzzy10 -0.923';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);