#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[_a-zA-Z]\w*\s*(\[.*\])?"
Local $sString = "foo" & @CRLF & _
"bar[1]" & @CRLF & _
"baz[1:5:1]" & @CRLF & _
"qux[[1,2,3]]" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"This does not work:" & @CRLF & _
"" & @CRLF & _
"foo + bar[1] + baz[1:10:var1[2+1]] + qux[[1,2,int(var2)]] + bob[len("foobar")] + func() + func2 (var3[0])" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")