const regex = /[_a-zA-Z]\w*\s*(\[.*\])?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[_a-zA-Z]\\w*\\s*(\\[.*\\])?', 'gm')
const str = `foo
bar[1]
baz[1:5:1]
qux[[1,2,3]]
This does not work:
foo + bar[1] + baz[1:10:var1[2+1]] + qux[[1,2,int(var2)]] + bob[len("foobar")] + func() + func2 (var3[0])
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}