package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((http[s]?|ftp):\/)?\/?([^:\/\s]+)((\/\w+)*\/)([\w\-\.]+[^#?\s]+)(.*)?(#[\w\-]+)?$`)
var str = `https://www.lowcarboncontracts.uk/file/893/download?token=SI4BHJyU`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}