// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^[[:alnum:]]{3}---[[:alnum:]]{2}-[[:alnum:]]{9}-[[:alnum:]]{4}.gvt1.com$").unwrap();
let string = "rr1---sn-pjvo2aopq-jb3e.gvt1.com";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}