use strict;
my $str = 'BE15-7878-0144-5741
BE15001470142457
BE1235-16152-216510-152615620
';
my $regex = qr/(BE)[1-9]{2}(-?)[0-9]{4}(-?)[0-9]{4}(-?)[0-9]{4}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}