re = /(\R{2})\R+|(\R){2}/m
str = 'line1
line2
line3
line4
line5'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result