$re = '/\/frontend\/([\w]+)\/?([0-9]+)?\/?/is';
$str = '/frontend/ajax_adasd/123,asdzxcvzxcvasdf';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);