using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^\d\p{L}.,\s]+";
string substitution = @"";
string input = @"L'élève s'est cassé la figure!
Il faut appeler le numéro 118 en cas d'accident.
#drop-some-chars";
RegexOptions options = RegexOptions.CultureInvariant;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}