use strict;
my $str = 'L\'élève s\'est cassé la figure!
Il faut appeler le numéro 118 en cas d\'accident.
#drop-some-chars';
my $regex = qr/[^\d\p{L}.,\s]+/up;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";