re = /(?:{{([\w-]+(?: [\w-]+)*)|\G(?!$))(?:\h+\[([^]]+)\])?(?=.*})/m
str = '{{word with spaces}}
{{word with spaces [sub1]}
{{word with spaces [sub1] [sub 2] [Sub-3] }}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end