# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=\"id\"\:)\d+(?=\,)"
test_str = ("{\n"
	"    \"id\": 5987431,\n"
	"    \"remoteRef\": \"f150edeab22e5458a8d5db64280023f0\",\n"
	"    \"paymentEntityType\": \"Bank\",\n"
	"    \"accountHolder\": \"Svilen Varbanov\",\n"
	"    \"accountNumber\": \"********6691\",\n"
	"    \"expiresEnd\": null,\n"
	"    \"paymentEntityStatus\": \"Unverified\",\n"
	"    \"token\": null,\n"
	"    \"canDeposit\": false,\n"
	"    \"canWithdraw\": false,\n"
	"    \"lastUsed\": false,\n"
	"    \"cardType\": null,\n"
	"    \"logs\": [\n"
	"        {\n"
	"            \"paymentEntityStatus\": \"Unverified\",\n"
	"            \"message\": \"Bank payment entity has been created.\",\n"
	"            \"updated\": \"2019-10-01 11:49:22Z\"\n"
	"        }\n"
	"    ],\n"
	"    \"transactionSummaries\": null,\n"
	"    \"paymentGateway\": \"RBC\",\n"
	"    \"details\": {\n"
	"        \"bankName\": null,\n"
	"        \"sortCode\": null,\n"
	"        \"swiftCode\": null,\n"
	"        \"branchCode\": null,\n"
	"        \"branchAddress\": null,\n"
	"        \"transitNumber\": \"340\",\n"
	"        \"institutionNumber\": \"34103\",\n"
	"        \"accountId\": \"575876691\"\n"
	"    },\n"
	"    \"createdAt\": \"2019-10-01T11:49:22.4680708Z\"\n"
	"}")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
    
    print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
    
    for groupNum in range(0, len(match.groups())):
        groupNum = groupNum + 1
        
        print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.