use strict;
my $str = '[{
"54ffe69-b8f6-47c8-9437-ccea8ecc2d77": {
"name": "ORC",
"$description": "Design polar from ORC",
"source": {
"label": "signalk-polar"
},
"polarData": [{
"trueWindSpeed": 3.086666667,
"beatAngles": [
0.738274274
]
}]
}
}]';
my $regex = qr/[0-9a-f]{7}-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{12}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}