$re = '/https?:\/\/[a-z]{1,}\.[a-z]{1,}(\.[a-z]{1,})+/m';
$str = 'https://www.abnamro.nl.co.uk
http://www.abnamro.nl';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);