#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b(?>1(?:01)*0?|0(?:10)*1?)\b"
Local $sString = "no binary numbers here 3434." & @CRLF & _
"Hey friend this is a 1." & @CRLF & _
"Those are 1001, 1010, 1011, 1100, 1101" & @CRLF & _
"This is a long value 10101010101 and this one as well 1010101010101011" & @CRLF & _
"0 + 0 is a also a 0." & @CRLF & _
"1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")