# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b(?>1(?:01)*0?|0(?:10)*1?)\b"
test_str = ("no binary numbers here 3434.\n"
"Hey friend this is a 1.\n"
"Those are 1001, 1010, 1011, 1100, 1101\n"
"This is a long value 10101010101 and this one as well 1010101010101011\n"
"0 + 0 is a also a 0.\n"
"1")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.