using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!Zn)(\.\s)";
string input = @"aaa. Zn. bbb
aaa. Zn. bbb.
aaa Zn. bbb.
aaa Zn. bbb
aaa Bns. bbb
aaa Bns. Bbb
aaa Zn. Aaa Bns. Bbb
1
aaa
aaa.
aaa Abbb
aaa. Zns. bbb
aaa. Zns. bbb.
aaa Zns. bbb.
aaa Zns. bbb";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}