re = /[0-9]/m
str = 'Create a regex that will recognize valid non-temporary Canadian social insurance numbers (SIN). An SIN has nine digits in three groups of three separated by a hyphen. Temporary SINs start with a 9.
956-943-987
123-456-987
123456789
908764392
956 - 543 - 432
956 - 543 - 432'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end