package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([a-zA-Z]{4}\.[a-zA-Z]{5}).*as ([a-zA-Z]+)`)
var str = `cast (mara.attyp as prodcategory preserving type ) as ProductCategory`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}