// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([a-zA-Z]{4}\.[a-zA-Z]{5}).*as ([a-zA-Z]+)").unwrap();
let string = "cast (mara.attyp as prodcategory preserving type ) as ProductCategory";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}