package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[\d+\/\d+\/\d+,\s\d+:\d+:\d+\d+\s\w*\]`)
var str = `[8/23/18, 2:05:50 PM]
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}