$re = '/(?<quote>[\'"])(?:(?!\k<quote>).)*\k<quote>/m';
$str = 'stuff "Something" stuff
stuff \'something\' stuff
stuff "Today\'s Top 10" stuff
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);