$re = '/\b(?!\w*([sar])\w*\1)(?!(?:\w*t){3})[sart]{3,}\b/m';
$str = 'rar sas aaa rtt at sit start, tarts, arts, art ttt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);