using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*(7\d{6}).*";
string substitution = @"$1";
string input = @"aksjhaksghlkas NSLsf
sklvbaskjhbvak vjadv 09,00mm
123456416584 7001122 asvljalskjfg 564563
34893 ajksha";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}