import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*(7\\d{6}).*";
final String string = "aksjhaksghlkas NSLsf\n"
+ "sklvbaskjhbvak vjadv 09,00mm\n"
+ "123456416584 7001122 asvljalskjfg 564563\n"
+ "34893 ajksha";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}