use strict;
my $str = 'aksjhaksghlkas NSLsf
sklvbaskjhbvak vjadv 09,00mm
123456416584 7001122 asvljalskjfg 564563
34893 ajksha';
my $regex = qr/.*(7\d{6}).*/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";