# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".*(7\d{6}).*"
test_str = ("aksjhaksghlkas NSLsf\n"
"sklvbaskjhbvak vjadv 09,00mm\n"
"123456416584 7001122 asvljalskjfg 564563\n"
"34893 ajksha")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.