use strict;
my $str = '12345-LATIS
234134-CRISE
13241234-P-ORACLE
134134-ORACLE
1341324-ENS
134134-P-NIBS
134123415-LATIS
11513423-CRISE
1-34555
A-33433
12-23434
5-3451-A
';
my $regex = qr/([^-]*)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}