import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!\\-)(?:(?:[a-zA-Z\\d][a-zA-Z\\d\\-]{0,61})?[a-zA-Z\\d]\\.){1,126}(?!\\d+)[a-zA-Z\\d]{1,63}$";
final String string = "invalid-.domains\n"
+ "-domain.com\n"
+ "domain--.com\n"
+ "-domain-.-.com\n"
+ "domain.000\n"
+ ".domain.net\n"
+ "domain.net.\n"
+ "sub.-domain.com\n"
+ "sub.domain-.com\n"
+ "sub-.domain.com\n"
+ "-sub.domain.com\n\n"
+ "valid.domains.below\n"
+ "schools.k12\n"
+ "newTLD.clothing\n"
+ "good.photography\n"
+ "x.a-b.com\n"
+ "x-y.a-b.net\n"
+ "x-y.a-b-c.co.uk\n"
+ "x.0ac.com\n"
+ "schools.k12\n"
+ "newTLD.clothing\n"
+ "good.photography\n"
+ "0-1-2.3-4.co\n"
+ "a-----b.com\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}