#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[\w]+.*\.[3mw][mp34ag].$"
Local $sString = "hdhdgd.mp3" & @CRLF & _
"sgsg.wma" & @CRLF & _
"" & @CRLF & _
"fdfdfd hgg-dgdg.3gp" & @CRLF & _
"Emachichi-Hakuna Mungu kama wewe.mp3" & @CRLF & _
"" & @CRLF & _
"gdgd gdfdf yddfr.mp3" & @CRLF & _
"tetete.txt" & @CRLF & _
"4f1c262493d4caf70d593226b3c73e00_direction.txt" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")