use strict;
my $str = 'hdhdgd.mp3
sgsg.wma
fdfdfd hgg-dgdg.3gp
Emachichi-Hakuna Mungu kama wewe.mp3
gdgd gdfdf yddfr.mp3
tetete.txt
4f1c262493d4caf70d593226b3c73e00_direction.txt
';
my $regex = qr/[\w]+.*\.[3mw][mp34ag].$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}