const regex = /^((?!\b(bobo|cu|porra|Pinto)\b).)+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?!\\b(bobo|cu|porra|Pinto)\\b).)+$', 'gm')
const str = `bobo
boboteste
cuca
cu
caracu
tomar no cu
cu doce
o cu da sua mae
que porra é essa
porrada
porra
João Pinto
Pintor`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}