$re = '/^((?!\b(bobo|cu|porra|Pinto)\b).)+$/m';
$str = 'bobo
boboteste
cuca
cu
caracu
tomar no cu
cu doce
o cu da sua mae
que porra é essa
porrada
porra
João Pinto
Pintor';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);