import re
regex = re.compile(r"^((?!\b(bobo|cu|porra|Pinto)\b).)+$", flags=re.MULTILINE)
test_str = ("bobo\n"
"boboteste\n"
"cuca\n"
"cu\n"
"caracu\n"
"tomar no cu\n"
"cu doce\n"
"o cu da sua mae\n"
"que porra é essa\n"
"porrada\n"
"porra\n"
"João Pinto\n"
"Pintor")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")