const regex = new RegExp('(?=\\b\\d{8}\\b)(?:(?:9?8?7?6?5?4?3?2?1?0?)|(?:0?1?2?3?4?5?6?7?8?9?))(?<=\\d{8})', 'gm')
const str = `This regex is to match Ascending or descending order of 8 digit number
01234567 0 to 7
12345678 1 to 8
23456789 2 to 9
12456789 missing 3
01236789 missing 4,5
23456789 missing 0,1
1234567
12345
012345678
123456789
0123456789
98765432 9 to 2
87654321 8 to 1
76543210 7 to 0
98765321 missing 4
96543210 missing 7,8
98765432 missing 0,1
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}