use strict;
my $str = 'This regex is to match Ascending or descending order of 8 digit number
01234567 0 to 7
12345678 1 to 8
23456789 2 to 9
12456789 missing 3
01236789 missing 4,5
23456789 missing 0,1
1234567
12345
012345678
123456789
0123456789
98765432 9 to 2
87654321 8 to 1
76543210 7 to 0
98765321 missing 4
96543210 missing 7,8
98765432 missing 0,1
';
my $regex = qr/(?=\b\d{8}\b)(?:(?:9?8?7?6?5?4?3?2?1?0?)|(?:0?1?2?3?4?5?6?7?8?9?))(?<=\d{8})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}