# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?=\b\d{8}\b)(?:(?:9?8?7?6?5?4?3?2?1?0?)|(?:0?1?2?3?4?5?6?7?8?9?))(?<=\d{8})"
test_str = ("This regex is to match Ascending or descending order of 8 digit number\n"
"01234567 0 to 7\n"
"12345678 1 to 8\n"
"23456789 2 to 9\n"
"12456789 missing 3\n"
"01236789 missing 4,5\n"
"23456789 missing 0,1\n"
"1234567\n"
"12345\n"
"012345678\n"
"123456789\n"
"0123456789\n"
"98765432 9 to 2\n"
"87654321 8 to 1\n"
"76543210 7 to 0\n"
"98765321 missing 4\n"
"96543210 missing 7,8\n"
"98765432 missing 0,1\n\n\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.