use strict;
my $str = '02022014
222014';
my $regex = qr/^(((0[1-9]|1[012])[- \/.]?(0[1-9]|[12][0-9]|3[01])[- \/.]?(19|20)\d\d)|((((0?[13578])|(1[02]))[- \/.]?((0?[1-9])|([12][0-9])|(3[01]))|((0?[469])|(11))[- \/.]?((0?[1-9])|([12][0-9])|(30))|(0?[2])[- \/.]?((0?[1-9])|([1][0-9])|([2][0-8])))[- \/.]?(19\d{2}|20\d{2}))|(((0?[2]))[- \/.]?((0?[1-9])|([12][0-9]))[- \/.]?((19|20)(04|08|[2468][048]|[13579][26])|2000)))$/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}