# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(((0[1-9]|1[012])[- \/.]?(0[1-9]|[12][0-9]|3[01])[- \/.]?(19|20)\d\d)|((((0?[13578])|(1[02]))[- \/.]?((0?[1-9])|([12][0-9])|(3[01]))|((0?[469])|(11))[- \/.]?((0?[1-9])|([12][0-9])|(30))|(0?[2])[- \/.]?((0?[1-9])|([1][0-9])|([2][0-8])))[- \/.]?(19\d{2}|20\d{2}))|(((0?[2]))[- \/.]?((0?[1-9])|([12][0-9]))[- \/.]?((19|20)(04|08|[2468][048]|[13579][26])|2000)))$"
test_str = ("02022014\n"
"222014")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.