import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\[\\S+\\s+\\S+\\s+\\S+\\s+\\S+\\s+\\S+\\] \\[(\\S*:)?(?:error|info)\\] (\\[pid \\d+(:tid \\d+)?\\] )?\\[client (\\S+)\\] (\\w+: )?File does not exist\\:";
final String string = "[Tue Feb 09 05:02:22.769263 2021] [core:error] [pid 83886:tid 140340187059968] [client 192.168.1.133:53478] AH00128: File does not exist: /var/www/vhosts/example.com/httpdocs/test.png\n"
+ "[Tue Feb 09 05:02:23.986502 2021] [core:info] [pid 83885:tid 140340270987008] [client 192.168.1.133:53482] AH00128: File does not exist: /var/www/vhosts/example.com/httpdocs/test.png\n"
+ "[Tue Feb 09 05:02:24.480283 2021] [core:info] [pid 83885:tid 140340262594304] [client 192.168.1.133:53486] AH00128: File does not exist: /var/www/vhosts/example.com/httpdocs/test.png\n"
+ "[Tue Feb 09 05:02:24.882395 2021] [core:info] [pid 83886:tid 140340170274560] [client 192.168.1.133:53490] AH00128: File does not exist: /var/www/vhosts/example.com/httpdocs/test.png\n"
+ "[Tue Feb 09 05:02:25.224595 2021] [core:info] [pid 83884:tid 140340262594304] [client 192.168.1.133:53494] AH00128: File does not exist: /var/www/vhosts/example.com/httpdocs/test.png";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}